Download the PHP package samdark/yii2-psr-log-target without Composer

On this page you can find all versions of the php package samdark/yii2-psr-log-target. It is possible to download/install these versions without Composer. Possible dependencies are resolved automatically.

Please rate this library. Is it a good library?

All versions of yii2-psr-log-target with dependencies

Informations about the package yii2-psr-log-target

Yii 2 PSR Log Target

Allows you to process logs using any PSR-3 compatible logger such as Monolog.

Latest Stable Version Total Downloads Build Status Code Coverage Scrutinizer Quality Score

Installation

Usage

In order to use PsrTarget you should configure your log application component like the following:

Standard usage:

Usage with PSR logger levels:

Usage with original timestamp from context in the log:

You can use PsrMessage instead of regular string messages to add custom context.

Standard usage:

Usage with PSR logger Levels:

Usage with PSR-3 log message processing:

Running tests

In order to run tests perform the following commands:


Version
Requires yiisoft/yii2 Version ~2.0.0
psr/log Version ~1.0.2|~1.1.0

The package samdark/yii2-psr-log-target contains the following files

Loading the files please wait ....