Download the PHP package linwj/bitmex without Composer

On this page you can find all versions of the php package linwj/bitmex. It is possible to download/install these versions without Composer. Possible dependencies are resolved automatically.

Please rate this library. Is it a good library?

All versions of bitmex with dependencies

Informations about the package bitmex

It is recommended that you use the test server first

Online interface testing https://www.bitmex.com/api/explorer/

Address of the test https://testnet.bitmex.com

The official address https://www.bitmex.com

All interface methods are initialized the same as those provided by Bitmex. See details src/api

Support Websocket

Most of the interface is now complete, and the user can continue to extend it based on my design, working with me to improve it.

中文文档

Other exchanges API

Exchanges It includes all of the following exchanges and is highly recommended.

Bitmex Support Websocket

Okex Support Websocket

Huobi Support Websocket

Binance Support Websocket

Kucoin

Mxc

Coinbase

ZB

Bitfinex

Bittrex

Kraken

Gate

Bigone

Crex24

Bybit

Coinbene

Bitget

Poloniex

If you don't find the exchange SDK you want, you can tell me and I'll join them.

Installation

Support for more request Settings More

Book Data More

Order More

Postion More

More Test

More API

Websocket

Websocket has two services, server and client. The server is responsible for dealing with the new connection of the exchange, data receiving, authentication and login. Client is responsible for obtaining and processing data.

Server initialization must be started in Linux CLI mode.

If you want to test, you can "php server.php start" immediately outputs the log at the terminal.

If you want to deploy, you can "php server.php start -d" enables resident process mode, and enables "log=>true" to view logs.

More Test

Client side initialization.

Subscribe

Unsubscribe

Get all channel subscription data

Get partial channel subscription data

Get partial private channel subscription data


Version
Requires php Version >=7.0
guzzlehttp/guzzle Version *
workerman/workerman Version *
workerman/globaldata Version *

The package linwj/bitmex contains the following files

Loading the files please wait ....