Download the PHP package spectrocoin/whmcs-merchant without Composer

On this page you can find all versions of the php package spectrocoin/whmcs-merchant. It is possible to download/install these versions without Composer. Possible dependencies are resolved automatically.

Please rate this library. Is it a good library?

All versions of whmcs-merchant with dependencies

Informations about the package whmcs-merchant

SpectroCoin WHMCS Bitcoin Payment Extension

This is a SpectroCoin Bitcoin Payment Module for WHMCS. This extenstion allows to easily accept bitcoins (and other cryptocurrencies such as DASH) at your WHMCS powered website. You can find a how to install this extenstion. You can view a tutorial how to integrate bitcoin payments for WHMCS.

To succesfully use this plugin, you have to have a SpectroCoin Bitcoin wallet. You can get it here. Also you have to create a merchant project to get merchant and project IDs, to do so create a new merchant project here.

INSTALLATION

  1. Upload module content to your WHMCS/modules/gateways folder.
    OR
    Navigate to WHMCS directory and run:

    composer require spectrocoin/whmcs-merchant
  2. Generate private key
    i. Automatically

    Go to SpectroCoin -> Project list click on your project, then select "Edit Project and then click "Generate" (next to Public key field), as a result you will get an automatically generated private key, download and save it. The matching Public key will be generated automatically and added to your project.

    ii. Manually

    Private key:


CONFIGURATION

  1. Go to Setup -> Payments -> Payment Gateways -> All Payment Gateways
  2. Select "Bitcoin provided by SpectroCoin" and press Activate
  3. Enter your Merchant ID, Project ID and Private key.

INFORMATION

This plugin has been developed by SpectroCoin.com If you need any further support regarding our services you can contact us via:
E-mail: [email protected]
Phone: +372 683 8000
Skype: spectrocoin_merchant
Web: https://spectrocoin.com
Twitter: @spectrocoin
Facebook: SpectroCoin


Version
Requires composer/installers Version ^1.10

The package spectrocoin/whmcs-merchant contains the following files

Loading the files please wait ....