Download the PHP library prooph/psb-bernard-producer

On this page you can find all versions of the php package prooph/psb-bernard-producer. It is possible to download/install these versions without Composer. Possible dependencies are resolved automatically.

Please rate this library. Is it a good library?

All versions of psb-bernard-producer with dependencies

Version
Requires php Version ~7.1
prooph/common Version ^4.1
bernard/bernard Version 1.0.*@dev
react/promise Version ^2.7

Informations about the package psb-bernard-producer

Bernard Message Producer for Prooph Service Bus

Build Status Coverage Status Gitter

Use Bernard as message producer for Prooph Service Bus.

Important

This library will receive support until December 31, 2019 and will then be deprecated.

For further information see the official announcement here: https://www.sasaprolic.com/2018/08/the-future-of-prooph-components.html

Installation

You can install the producer via composer by adding "prooph/psb-bernard-producer": "^1.0" as requirement to your composer.json.

Usage

Check the BernardMessageProducerTest. Set up the producer is a straightforward task. Most of the required components are provided by PSB and Bernard. This package only provides the glue code needed to let both systems work together.

Support

Contribute

Please feel free to fork and extend existing or add new features and send a pull request with your changes! To establish a consistent code quality, please provide unit tests for all your changes and may adapt the documentation.

License

Released under the New BSD License.


The package prooph/psb-bernard-producer contains the following files

Loading the files please wait ....