Download the PHP package justbetter/magento2-deployer-plus without Composer
On this page you can find all versions of the php package justbetter/magento2-deployer-plus. It is possible to download/install these versions without Composer. Possible dependencies are resolved automatically.
Download justbetter/magento2-deployer-plus
More information about justbetter/magento2-deployer-plus
Files in justbetter/magento2-deployer-plus
Package magento2-deployer-plus
Short Description Magento 2 deployment tool based on deployer.org
License GPL-3.0
Informations about the package magento2-deployer-plus
JustBetter - Magento 2 Deployer Plus
- Reliable fully-automated deployments tool for Magento 2.
- Zero downtime deployments on Magento versions >= 2.2
- Automating your deployments is as easy as defining the servers where you want to deploy to.
Archived
All features this offered are already available in deployer itself at this point see Migrate your deployments to use that instead.
Motivation
This project aims to offer a common solution for fully-automated deployments on all versions of Magento 2. This tool uses the well known Deployer and adds specific recipes for each Magento 2 version.
Important Features
- Deployer code syntax
- Super easy setup
- Deploy to multiple servers
- Zero Downtime (only Magento >= 2.2)
- Build and Deploy artifacts (only Magento >= 2.2)
- Secure rollbacks (only Magento >= 2.2)
Installation
Setup
Magento >= 2.1
Magento >= 2.2
Magento >= 2.2.5
Usage
Git deploys:
Build artifact deploys: (only Magento >= 2.2)
Troubleshooting
Js translations missing (magento versions >=2.1.3 <2.2.1)
-
Problem: Known Magento issue when executing
setup:static-content:deployfor several languages. -
Github Issues:
- Solution: Until that gets fixed in
2.2.1, the only workaround is to executesetup:static-content:deployindividually for each language:
Compilation error
- Solution: Increase php
memory_limitconfiguration to 728M o 1024M
Static deploy error when setting a new template (if config propagation is not used)
- Problems:
[LogicException] Unable to load theme by specified key: 'Template'@variableis undefined in file
- Reason: If a new template is set, running
setup:upgradeis required before executingsetup:static-content:deploy -
Solution: Skip
setup:static-content:deployfirst time you deploy the new template:-
Temporary disable task
files:static_assets - Perform a new release
-
Enable back
files:static_assetson yourdeploy.phpfile- Remove
task('files:static_assets')->onRoles('Skip');
- Remove
- Manually execute
files:static_assets
After that, future deployments will work without issues
-
Prerequisites
- PHP >= 8.0
- MAGENTO >= 2.1
ChangeLog
CHANGELOG.md
Developers
Licence
GNU General Public License, version 3 (GPLv3)
Copyright
(c) JustBetter B.V. [email protected]