Download the PHP package horde/imap-client without Composer

On this page you can find all versions of the php package horde/imap-client. It is possible to download/install these versions without Composer. Possible dependencies are resolved automatically.

FAQ

After the download, you have to make one include require_once('vendor/autoload.php');. After that you have to import the classes with use statements.

Example:
If you use only one package a project is not needed. But if you use more then one package, without a project it is not possible to import the classes with use statements.

In general, it is recommended to use always a project to download your libraries. In an application normally there is more than one library needed.
Some PHP packages are not free to download and because of that hosted in private repositories. In this case some credentials are needed to access such packages. Please use the auth.json textarea to insert credentials, if a package is coming from a private repository. You can look here for more information.

  • Some hosting areas are not accessible by a terminal or SSH. Then it is not possible to use Composer.
  • To use Composer is sometimes complicated. Especially for beginners.
  • Composer needs much resources. Sometimes they are not available on a simple webspace.
  • If you are using private repositories you don't need to share your credentials. You can set up everything on our site and then you provide a simple download link to your team member.
  • Simplify your Composer build process. Use our own command line tool to download the vendor folder as binary. This makes your build process faster and you don't need to expose your credentials for private repositories.
Please rate this library. Is it a good library?

Informations about the package imap-client

Horde_Imap_Client

An IMAP4rev1 / IMAP4rev2 (RFC 3501 / RFC 9051) and POP3 (RFC 1939) client library for PHP.

The package ships two codebases side by side:

Modern usage

ImapClient implements ImapProtocol (and MailboxProtocol), plus the optional ImapAclAware, ImapQuotaAware and ImapMetadataAware extension interfaces. Pop3Client implements MailboxProtocol.

Message caching is opt-in: pass an ImapCacheStore (backed by any PSR-16 cache) as the fifth ImapClient constructor argument and it is used transparently across fetch, store and expunge.

Supported extensions

STARTTLS, SASL (via Horde\Sasl), CAPABILITY/ENABLE, IMAP4rev2, UTF8=ACCEPT, UIDPLUS, MOVE, CONDSTORE/QRESYNC, ESEARCH, SORT/ESORT, THREAD, LIST-EXTENDED, LIST-STATUS, NAMESPACE, ACL, QUOTA, METADATA, MULTIAPPEND, CATENATE, BINARY and SEARCH=FUZZY.

Documentation

License

LGPL 2.1. See the enclosed LICENSE file.


All versions of imap-client with dependencies

PHP Build Version
Package Version
No informations.
Composer command for our command line client (download client) This client runs in each environment. You don't need a specific PHP version etc. The first 20 API calls are free. Standard composer command

The package horde/imap-client contains the following files

Loading the files please wait ...