Download the PHP package diegomagikal/laravel-password without Composer

On this page you can find all versions of the php package diegomagikal/laravel-password. It is possible to download/install these versions without Composer. Possible dependencies are resolved automatically.

Please rate this library. Is it a good library?

All versions of laravel-password with dependencies

Informations about the package laravel-password

laravel-password

Latest Stable Version Quality Score Total Downloads

Guard your users from security problems by preventing them from having dumb passwords

Introduction

This package can be used to verify the user provided password is not one of the top 10,000 worst passwords as analyzed by a respectable IT security analyst. Read about all here, here(wired) or here(telegram)

Installation

PHP 5.5+ or HHVM 3.3+, and Composer are required.

To get the latest version of Laravel Password, simply add the following line to the require block of your composer.json file.

You'll then need to run composer install or composer update to download it and have the autoloader updated.

Usage

Use the rule checkpassword in your validation like so:

Error shows on the page like so:

screen shot 2016-07-02 at 2 12 14 pm screen shot 2016-07-02 at 1 22 45 pm

By default, the error message returned is This password is just too common. Please try another!.

You can customize the error message by opening resources/lang/en/validation.php and adding to the array like so:

Change log

Please see CHANGELOG for more information on what has changed recently.

Contributing

Please feel free to fork this package and contribute by submitting a pull request to enhance the functionalities.

Inspiration

How can I thank you?

Why not star the github repo? I'd love the attention!

License

The MIT License (MIT). Please see License File for more information.


Version
Requires php Version ~5.6|~7.0

The package diegomagikal/laravel-password contains the following files

Loading the files please wait ....