Download the PHP package consolibyte/quickbooks without Composer

On this page you can find all versions of the php package consolibyte/quickbooks. It is possible to download/install these versions without Composer. Possible dependencies are resolved automatically.

Please rate this library. Is it a good library?

All versions of quickbooks with dependencies

Informations about the package quickbooks

QuickBooks PHP DevKit

QuickBooks integration support for PHP 5.x+

The package you've downloaded contains code and documentation for connecting various versions and editions of QuickBooks to PHP, allowing your PHP applications to do fancy things like:

Almost anything you can do in the QuickBooks GUI, in QuickBooks Online Edition, and with QuickBooks Merchant Service can be accomplished via this framework.

Quick Start Guides

OAuth 1.0 to OAuth 2.0 migration

You can find information on how to migrate your app from OAuth v1.0 to OAuth v2.0 below. We are also working on getting OpenID Connect and an automated token migration process ready -- coming soon.

Updates and Improvements

Please follow me on Twitter to be notified about updates/improvements:

Support

Questions/general support

Before you ask for help make sure you:

Now that you have the output of the troubleshooting.php script and your code together, ask in one of these two places:

Bugs/pull requests

Examples

You will find examples in the docs/ folder.

Examples for QuickBooks ONLINE

If you are using QuickBooks ONLINE, then you need to look in this folder for examples:

Make sure you look at the [quick start guide for Intuit Partner Platform/QuickBooks Online] (http://www.consolibyte.com/docs/index.php/PHP_DevKit_for_QuickBooks_-_Intuit_Partner_Platform_Quick-Start)

Examples for QuickBooks FOR WINDOWS

If you are using QuickBooks FOR WINDOWS, then you need to look in this folder for examples:

Make sure you look at the quick start guide for the Web Connector/QuickBooks for Windows

Additional Info

There is additional documentation and additional examples on our legacy and new wikis:


Keith Palmer


Version
Requires php Version >=5.0.0

The package consolibyte/quickbooks contains the following files

Loading the files please wait ....