Download the PHP package bitwasp/bitcoin-lib without Composer

On this page you can find all versions of the php package bitwasp/bitcoin-lib. It is possible to download/install these versions without Composer. Possible dependencies are resolved automatically.

Please rate this library. Is it a good library?

All versions of bitcoin-lib with dependencies

Informations about the package bitcoin-lib

bitcoin-lib-php

PHP libraries implementing bitcoin key functions, as well as BIP32 and electrum.

Gitter

NB: This library is outdated, and no longer maintained. BC breaks will not be accepted for this reason. For a newer library, please see https://github.com/Bit-Wasp/bitcoin-php

The library intends to expose a lot of general functionality which isn't available using the RPC (like deterministic addresses).

It also allows you to reduce the number of queries that are made to bitcoind, such as createrawtransaction/signrawtransaction/decoderawtransaction. As such, such, use of bitcoin RPC functionality can be kept to a minimum.

Libraries

If this library powers your project and you're feeling tipsy, buy me lunch some day! 1sCVtkEhQmvp3D4K22Pw9xhFPTDWFh8SZ

Installation

Installing via Composer (recommended)

  1. Install Composer in your project:

    curl -s http://getcomposer.org/installer | php

  2. Create a composer.json file in your project root:

    { "require": { "bitwasp/bitcoin-lib": "1.0.*" } }

  3. Install via Composer

    php composer.phar install

Dependencies

Mcrypt Extension (Random data)

The Mcrypt Extension is required for generating random data, it does this internally by using /dev/urandom on unix or CryptGenRandom on windows.

GMP Extension (Math)

The GMP Extension is required for the crypto math.

PECL intl extension (BIP39)

The PECL intl extension is required for BIP39 Mnemonic Seeds when a UTF-8 passphrase is used.

Mdanter's PHP Pure PHP Elliptic Curve Cryptography Library

mdanter/ecc is required for most of the crypto.

Contributing

Please make sure that all phpunit tests pass (and preferably added new unit tests) and that the coding style passing PSR2 checks:


Version
Requires mdanter/ecc Version ~0.3.0
php Version >=5.3.3
rych/hash_pbkdf2-compat Version ~1.0
ext-gmp Version *
ext-bcmath Version *
ext-mcrypt Version *

The package bitwasp/bitcoin-lib contains the following files

Loading the files please wait ....