Download the PHP package automattic/phpcs-neutron-standard without Composer

On this page you can find all versions of the php package automattic/phpcs-neutron-standard. It is possible to download/install these versions without Composer. Possible dependencies are resolved automatically.

Please rate this library. Is it a good library?

All versions of phpcs-neutron-standard with dependencies

Informations about the package phpcs-neutron-standard

Neutron PHP Standard Build status

These are a set of modern (PHP >7) linting guidelines meant to be applied in addition to the the WordPress coding standards for WordPress development. Because of the newer PHP version, it is not suitable for work on Core WordPress, but may be useful for those who are not bound by PHP 5.2.

These guidelines are being developed primarily for a team within Automattic, but anyone is free to use them, suggest changes, or report bugs.

This project is a phpcs "standard" (a collection of rules or "sniffs") that can be included in any project.

Installation

To use these rules in a project which is set up using composer, we recommend using the phpcodesniffer-composer-installer library which will automatically use all installed standards in the current project with the composer type phpcodesniffer-standard when you run phpcs.

If you want this standard, the WordPress standard, the VariableAnalysis standard, and other customizations, you can install the meta-standard NeutronRuleset instead.

Configuration

When installing sniff standards in a project, you edit a phpcs.xml file with the rule tag inside the ruleset tag. The ref attribute of that tag should specify a standard, category, sniff, or error code to enable. It’s also possible to use these tags to disable or modify certain rules. The official annotated file explains how to do this.

Usage

Most editors have a phpcs plugin available, but you can also run phpcs manually. To run phpcs on a file in your project, just use the command-line as follows (the -s causes the sniff code to be shown, which is very important for learning about an error).


Guidelines

View the Guidelines here.


Version
Requires php Version ^7.0

The package automattic/phpcs-neutron-standard contains the following files

Loading the files please wait ....