Download the PHP package arrayaccess/rdap-client without Composer
On this page you can find all versions of the php package arrayaccess/rdap-client. It is possible to download/install these versions without Composer. Possible dependencies are resolved automatically.
Download arrayaccess/rdap-client
More information about arrayaccess/rdap-client
Files in arrayaccess/rdap-client
Package rdap-client
Short Description Registration Data Access Protocol (RDAP) Client For PHP
License GPL-3.0-or-later
Informations about the package rdap-client
RDAP CLIENT
RDAP Client For PHP (Formerly Whois via http protocol)
Requirements
- php
8.1or later ext-jsonext-intl
IETF RDAP Reference
- Registration Data Access Protocol (RDAP) Object Tagging #RFC8521
- Security Services for the Registration Data Access Protocol (RDAP) #RFC7481
- Registration Data Access Protocol (RDAP) Query Format #RFC9082
- JSON Responses for the Registration Data Access Protocol (RDAP) #RFC9083
- Finding the Authoritative Registration Data (RDAP) Service #RFC9224
Schema Inventory & Analysis of WHOIS object
- Inventory and Analysis of WHOIS Registration Objects #RFC7485
IANA RDAP Data
Iana provide data about rdap
-
HTTP : https://data.iana.org/rdap/
- Bootstrap Service Registry for AS Number Space #RFC9224 https://www.iana.org/assignments/rdap-asn/rdap-asn.xhtml
- Bootstrap Service Registry for Domain Name Space #RFC9224 https://www.iana.org/assignments/rdap-dns/rdap-dns.xhtml
- Bootstrap Service Registry for IPv4 Address Space #RFC9224 https://www.iana.org/assignments/rdap-ipv4/rdap-ipv4.xhtml
- Bootstrap Service Registry for IPv6 Address Space #RFC9224 https://www.iana.org/assignments/rdap-ipv6/rdap-ipv6.xhtml
- Bootstrap Service Registry for Provider Object Tags #RFC8521 https://www.iana.org/assignments/rdap-object-tags/rdap-object-tags.xhtml
- Recovered IPv4 Pool #RFC8521 https://www.iana.org/assignments/ipv4-recovered-address-space/ipv4-recovered-address-space.xhtml
For list of predefined recovered IPv4 addresses: RecoveredIPv4.php
Example Usage
See Client.php for more methods
See Response/Definitions for more details about code
Using your own HTTP client and cache
By default, requests are made with file_get_contents() and the IANA bootstrap files are cached in the system temporary directory.
The client optionally accepts a PSR-18 HTTP client, a PSR-17 request factory and a PSR-16 cache. The HTTP client is used for both the bootstrap files and the RDAP queries, so timeouts, proxies, retries and logging follow your application's configuration. The cache stores the bootstrap files for AbstractRdapService::cacheExpirations() seconds.
Note
The code of data definition contains strict types. Some of the invalid data will throw an error.
WHOIS Data Collection
Refer to: (gist) WHOIS List to get the list of whois servers / ip range / sTLD etc.
Caution! the gist contains huge data.
LICENSE
GPL-3.0-or-later
All versions of rdap-client with dependencies
ext-intl Version *
ext-json Version *