Libraries tagged by rfc 1751
arokettu/rfc1751
31 Downloads
RFC 1751 Encoder/Decoder
clue/zlib-react
74138 Downloads
Streaming zlib compressor and decompressor for ReactPHP, supporting compression and decompression of GZIP, ZLIB and raw DEFLATE formats.
vaibhavpandeyvpz/jweety
24700 Downloads
Simple JWT (RFC 7519) encoding/decoding and validation library, for PHP >= 8.2.
alancting/php-microsoft-jwt
50346 Downloads
A simple library to validate and decode Microsoft Azure Active Directory (Azure AD), Microsoft Active Directory Federation Services (ADFS) JSON Web Tokens (JWT) in PHP, conforming to RFC 7519
studio-design/ecdsa-signature
2605 Downloads
ECDSA signature value object with DER/JWS raw format conversion and curve-order validation. For Cloud KMS/HSM-based JWT signing where OpenSSL/KMS returns DER but JWT (RFC 7518) requires raw format.
horde/jwt
2470 Downloads
Horde RFC 7519 JSON Web Token (JWT) Library
compwright/php-jwks
5058 Downloads
JSON Web Key tools for PHP per RFC-7517
medzuch/jwt-php
1179 Downloads
Standalone, RFC 7519 / 7797 / 8725-compliant JWT library for PHP 8.3 and 8.4. Framework-agnostic.
invenso/microsoft-jwt
6029 Downloads
A simple library to validate and decode Microsoft Azure Active Directory (Azure AD), Microsoft Active Directory Federation Services (ADFS) JSON Web Tokens (JWT) in PHP, conforming to RFC 7519
gandung/jwt
9 Downloads
Implementation Of JSON Web Token (RFC 7519)
bayfrontmedia/php-jwt
1044 Downloads
A simple library to encode and decode JSON Web Tokens (JWT) in PHP, conforming to RFC 7519.
remessage/json-web-token
55 Downloads
A JSON Web Token (RFC 7519) implementation library
matiasnamendola/slimpower-jwt
57 Downloads
A simple library to encode and decode JSON Web Tokens (JWT) in PHP, conforming to RFC 7519
loongs/oauth
1 Downloads
loong-swoole OAuth 2.1 authorization server + resource server — authorization_code with PKCE (S256), client_credentials, rotating refresh tokens, RFC 7009 revocation, RFC 7662 introspection, RFC 8414 metadata, RFC 9207 iss, encrypted RFC 9068 access tokens (nested JWS-in-JWE, RFC 7516); storage-agnostic core with loongs/orm (multi-tenant with loongs/saas), loongs/cache and memory stores
gozoro/jwt
9 Downloads
A simple PHP class to encode and decode JSON Web Tokens (JWT), conforming to RFC 7519.