Libraries tagged by RFC5321
horde/smtp
1574 Downloads
SMTP and LMTP client library
phpdot/smtp-gateway
5 Downloads
SMTP access gateway for PHP: accepts email from users' clients over SMTP, stores it, hands it to a transport.
php-standard-library/smtp
4 Downloads
RFC 5321 SMTP client for sending messages
ocubom/email-address
8627 Downloads
Email address value object checked against RFC 3696, RFC 1123, RFC 4291, RFC 5321 and RFC 5322.
2upmedia/emailaddressvalidator
94 Downloads
Michael Rushton's RFC 5321 and RFC 5321-compliant EmailAddressValidator class ported to composer
sabre/vobject
28760852 Downloads
The VObject library for PHP allows you to easily parse and manipulate iCalendar and vCard objects
kigkonsult/icalcreator
3113597 Downloads
iCalcreator is the PHP implementation of rfc2445/rfc5545 and rfc updates, management of calendar information
mmucklo/email-parse
947550 Downloads
RFC 5322 / RFC 6531-compliant library for batch parsing multiple (and single) email addresses
utopia-php/emails
178225 Downloads
Utopia Emails library is simple and lite library for parsing and validating email addresses. This library is aiming to be as simple and easy to learn and use.
protonlabs/vobject
57845 Downloads
The VObject library for PHP allows you to easily parse and manipulate iCalendar and vCard objects
phpfui/icalendar
21039 Downloads
A modern fork of the icalendar.org PHP implementation of rfc5545, management of iCal formatted files
php-extended/php-email-address-object
190398 Downloads
A library that implements the php-extended/php-email-address-interface interface library.
php-extended/php-email-address-interface
201209 Downloads
A library to represent email addresses and mailboxes
harungecit/php-email-validator
711 Downloads
The most complete email validation and disposable email detection library for PHP: 136,000+ disposable domains (updated daily, false-positive filtered), MX/DNS, RFC & spoof checks, role-based and typo detection, SMTP verification. Framework-agnostic with first-class Laravel, Symfony, CodeIgniter 4, CakePHP, Yii 2/3 and Phalcon integrations.
php-standard-library/message
203 Downloads
RFC 5322 internet message construction and parsing