Libraries tagged by RFC 7231
grazulex/laravel-apiroute
39713 Downloads
Complete API versioning lifecycle management for Laravel
hoa/http
235902 Downloads
The Hoa\Http library.
thingston/psr7
78 Downloads
Implementation of PSR-7 standard for representing HTTP messages as described in RFC 7230 and RFC 7231, and URIs for use with HTTP messages as described in RFC 3986.
ejetar/accept-header-interpreter
20 Downloads
Accept Header toolbox 🧰 to Laravel. Validation and interpretation based on RFC 7231, section 5.3.1 and 5.3.2. Conversion of the list of media types to ordered Laravel Collections (by priority, according to RFC).
noresources/ns-php-http-core
836 Downloads
HTTP core
noresources/http-core
173 Downloads
HTTP core
chiron/http-exceptions
2775 Downloads
Exception classes for Http Exception.
kevinrob/guzzle-cache-middleware
21178944 Downloads
A HTTP/1.1 Cache for Guzzle 6. It's a simple Middleware to be added in the HandlerStack. (RFC 7234)
sunrise/http-message
122872 Downloads
An HTTP message implementation based on PSR-7, PSR-17 and RFC-7230.
methorz/http-cache-middleware
71 Downloads
PSR-15 HTTP caching middleware with ETag support and RFC 7234 compliance
kuria/request-info
698 Downloads
Get information about the current HTTP request
madeorsk/forwarded
193 Downloads
Forwarded header (RFC 7239) parsing library for PHP.
coolms/mime
1 Downloads
A streaming MIME parser for PHP: RFC 5322 / 2045-2049 / 2047 / 2231 / 2183 / 6532, including message/rfc822 and message/global. No dependencies, no ext-mailparse.