Libraries tagged by RFC 5322
mmucklo/email-parse
926514 Downloads
RFC 5322 / RFC 6531-compliant library for batch parsing multiple (and single) email addresses
utopia-php/emails
175053 Downloads
Utopia Emails library is simple and lite library for parsing and validating email addresses. This library is aiming to be as simple and easy to learn and use.
php-extended/php-email-address-object
189837 Downloads
A library that implements the php-extended/php-email-address-interface interface library.
php-extended/php-email-address-interface
200527 Downloads
A library to represent email addresses and mailboxes
php-standard-library/message
169 Downloads
RFC 5322 internet message construction and parsing
snipershady/emailvalidator
27 Downloads
Simple, clean and reliable email validator for PHP >= 8.3: syntax, RFC 5322 format and MX/Null-MX record checks, with sanitized-address retrieval.
ocubom/email-address
8627 Downloads
Email address value object checked against RFC 3696, RFC 1123, RFC 4291, RFC 5321 and RFC 5322.
coolms/mime
0 Downloads
A streaming MIME parser for PHP: RFC 5322 / 2045-2049 / 2047 / 2231 / 2183 / 6532, including message/rfc822 and message/global. No dependencies, no ext-mailparse.
ukkz/mailparser
67 Downloads
An independent parser library for internet message format.
php-extended/php-email-address-parser-object
87692 Downloads
A library that implements the php-extended/php-email-address-parser-interface interface library.
php-extended/php-email-address-parser-interface
88570 Downloads
A library to parse email addresses, mailboxes, and lists of those that can be found in email headers
fubber/mini
69 Downloads
Forkable core PHP framework with zero dependencies beyond PSR interfaces: SQL-first database layer with a federated virtual SQL engine, PSR-15 routing, template inheritance, ICU i18n, RFC 5322 mail, JSON Schema validation — provides implementations for the PSR container, http-message, http-client, simple-cache and log contracts
php-standard-library/smtp
1 Downloads
RFC 5321 SMTP client for sending messages
2upmedia/emailaddressvalidator
94 Downloads
Michael Rushton's RFC 5321 and RFC 5321-compliant EmailAddressValidator class ported to composer