Libraries tagged by structure
bakame/http-structured-fields
22740 Downloads
A PHP library that parses, validates and serializes HTTP structured fields according to RFC9561 and RFC8941
pear/structures_graph
1875614 Downloads
More info available on: http://pear.php.net/package/Structures_Graph
lezhnev74/pasvl
62810 Downloads
Array Validator (regular expressions for nested array, sort of)
concretecms/doctrine-xml
157561 Downloads
Define database structure via XML using Doctrine data types
qaribou/immutable.php
150216 Downloads
Immutable, highly-performant collections, well-suited for functional programming and memory-intensive applications.
nayjest/tree
147365 Downloads
Tree data structure for PHP
hexogen/kdtree
105549 Downloads
file system KDTree index
doganoo/php-algorithms
6980 Downloads
A collection of common algorithms implemented in PHP. The collection is based on "Cracking the Coding Interview" by Gayle Laakmann McDowell
yiiext/activerecord-relation-behavior
39189 Downloads
Inspired by and put together the awesomeness of many yii extensions that aim to improve saving of related records. Comes with 100% test coverage and well structured and clean code so it can savely be used in enterprise production enviroment.
vaibhavpandeyvpz/phemail
140216 Downloads
A pure PHP MIME parser for parsing raw email files (.eml) with full support for multipart messages, nested structures, and RFC 2046 compliance.
typicms/typicms
222 Downloads
A modular multilingual CMS built with Laravel, enabling developers to manage structured content like pages, news, events, and more.
typicms/base
20421 Downloads
A modular multilingual CMS built with Laravel, enabling developers to manage structured content like pages, news, events, and more.
ruudk/code-generator
273080 Downloads
Yield your code line by line: let generators handle indentation, formatting, and structure for you
plumphp/plum
98725 Downloads
Plum is a data processing pipeline that helps you to write structured, reusable and well tested data processing code.
phunkie/phunkie
37421 Downloads
Functional structures library for PHP