Libraries tagged by RFC 6838
wccplatform/otphp
166 Downloads
A PHP library for generating one time passwords according to RFC 4226 (HOTP Algorithm) and the RFC 6238 (TOTP Algorithm) and compatible with Google Authenticator
top20ofe/two-factor-authentication
276 Downloads
Two Factor Authentication (2FA) for Laravel
beastbytes/yii-otp
13 Downloads
Library that simplifies using One Time Passwords (OTP) (HOTP or TOTP algorithm) in Yii3 applications
ipunkt/laravel-two-factor-authentication
51 Downloads
Two factor authentication (2FA) with TOTP tokens. (RFC 6238)
vulncue/totp
1 Downloads
Dependency-free PHP TOTP (RFC 6238) / HOTP (RFC 4226) implementation, verified against the official RFC test vectors.
up2dev/user-totp
2 Downloads
Ajoute un TOTP (2FA) optionnel et par utilisateur au-dessus d'un système d'authentification existant, sans le modifier. Aucun service externe : tout le calcul TOTP est local (RFC 6238).
ton-org/asafe2fa-php
49 Downloads
TOTP (RFC 6238) / Asafe compatible 2FA helper.
texdc/totp
354 Downloads
Simple TOTP (RFC 6238)
raisulhridoy/laravel-2fa
7 Downloads
Laravel 2FA is a PHP implementation of the Google Two-Factor Authentication Module, supporting the HMAC-Based One-time Password (HOTP) algorithm specified in RFC 4226 and the Time-based One-time Password (TOTP) algorithm specified in RFC 6238.
pieceofcake2/totp
2 Downloads
Two-factor authentication with time-based one-time passwords (TOTP, RFC 6238) for the CakePHP 2 AuthComponent
phpdot/totp
4 Downloads
Coroutine-safe, zero-dependency HOTP/TOTP (RFC 4226 / RFC 6238) with provisioning URIs for the PHPdot ecosystem.
olusegun171/laravel-mfa
29 Downloads
Multi-factor authentication for Laravel — TOTP compatible with Google Authenticator, Authy, and any RFC 6238 app.
ndtan/php-2fa
3 Downloads
NDT 2FA — TOTP (RFC 6238) for PHP with backup codes, otpauth URIs, and QR generation (SVG). Laravel & Symfony integrations included.
mindgruve/two-factor-auth
83 Downloads
PHP Implementation of RFC 6238 used by the Google Authenticator Token Generator
mika/otp
9 Downloads
HOTP according to RFC 4226 and TOTP according to RFC 6238.